实训目的

· 掌握VRRP配置方法。

实训背景

VRRP(Virtual Router Redundancy Protocol,虚拟路由冗余协议)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议。双核心的网络环境下,增强网络的稳定性,在主网关设备发生故障时,备份网关设备可以在不影响内外数据通信的前提下进行网关切换,且不需要再修改内部网络的设置。

例如:配置vlan10的虚拟网关192.168.10.254,选举sw3为master,sw4为backup switch ,并且当sw3的上行链路或者下行链路故障的时候。sw4被选举为master 。

实训拓扑

实训所需设备:

环境:EVE

设备: 1台PC,1台二层交换机,4台三层交换机

实训步骤

步骤1:基本配置

SW1:

Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#hostname SW1
SW1(config)#interface Ethernet0/0
SW1(config-if)#no switchport
SW1(config-if)#ip address 12.1.1.1 255.255.255.0
SW1(config-if)#no shutdown

SW2:

Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#hostname SW2
SW1(config)#interface Ethernet0/0
SW1(config-if)#no switchport
SW1(config-if)#ip address 13.1.1.1 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)#exit

SW3:

Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#hostname SW3
SW3(config)# interface Ethernet0/1
SW3(config-if)# no switchport
SW3(config-if)#ip address 12.1.1.2 255.255.255.0
SW3(config-if)#no shutdown
SW3(config)#interface Ethernet0/0
SW3(config-if)#switchport trunk encapsulation dot1q
SW3(config-if)#switchport mode trunk
SW3(config)#vlan 10
SW3(config-vlan)#exit
SW3(config)#interface Vlan10
SW3(config-if)#ip address 192.168.10.252 255.255.255.0
SW3(config-if)#no shutdown
SW3(config-if)#exit

SW4:

Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#hostname SW4
SW4(config)#interface Ethernet0/1
SW4(config-if)# no switchport
SW4(config-if)#ip address 13.1.1.2 255.255.255.0
SW4(config-if)#no shutdown
SW4(config)#interface Ethernet0/0
SW4(config-if)#switchport trunk encapsulation dot1q
SW4(config-if)#switchport mode trunk
SW4(config)#vlan 10
SW4(config-vlan)#exit
SW4(config)#interface Vlan10
SW4(config-if)#ip address 192.168.10.253 255.255.255.0
SW4(config-if)#no shutdown
SW4(config-if)#exit

SW5:

Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#hostname SW5
SW5(config)#interface rang e0/1-2
SW5(config-if)#switchport trunk encapsulation dot1q
SW5(config-if)#switchport mode trunk
SW5(config)#interface Ethernet0/0
SW5(config-if)#switchport mode access
SW5(config-if)#switchport access vlan 10
SW5(config-if)#exit
SW5(config)#vlan 10
SW5(config-vlan)#exit
SW5(config)#interface Vlan10
SW5(config-if)#ip address 192.168.10.10 255.255.255.0
SW5(config-if)#no shutdown
SW5(config-if)#exit
步骤2:VRRP配置

SW3:

SW3(confg)#track 1 interface Ethernet0/0 line-protocol    //vrrp的track追踪配置是在全局配置模式下配置,再到接口下应用
SW3(confg)#track 2 interface Ethernet0/1 line-protocol
SW3(config)#int vlan 10
SW3(config-if)#vrrp 1 ip 192.168.10.254  //创建组号为1的VRRP
SW3(config-if)#vrrp 1 priority 200  //越大越优先,默认值100
SW3(config-if)#vrrp 1 preempt   //设置为抢占模式,即一恢复就夺取控制权
SW3(config-if)#vrrp 1 track 1 decrement 60    //当e0/0口出现故障的时候,SW3的优先级降低60
SW3(config-if)#vrrp 1 track 2 decrement 60     //当e0/1口出现故障的时候,SW3的优先级降低60

SW4:

SW4(confg)#track 1 interface Ethernet0/0 line-protocol
SW4(confg)#track 2 interface Ethernet0/1 line-protocol
SW4(config)#int vlan 10
SW4(config-if)#vrrp 1 ip 192.168.10.254
SW4(config-if)#vrrp 1 priority 150
SW4(config-if)#vrrp 1 preempt
SW4(config-if)#vrrp 1 track 1 decrement 60     //当e0/0口出现故障的时候,SW4的优先级降低60
SW4(config-if)#vrrp 1 track 2 decrement 60     //当e0/1口出现故障的时候,SW4的优先级降低60

PC:

步骤4:查看VRRP
SW3#show vrrp bri

SW4#show vrrp bri

我们看到,SW3优先级(Priority)=200,SW4优先级(Priority)=150,所以SW3是 Master。

步骤5:断开SW3的e0/1接口,再次查看VRRP,sw3优先级降底60,将被选举为backup,sw4将被选举为master

再次查看VRRP

关闭e0/1口,SW3优先级降底60,但是由于无法与backup进行通信,因此SW3还是认为自己是主路由器。

备份路由器在连续三个通告间隔内收不到VRRP或收到优先级为0的通告后启动新的一轮VRRP选举,SW3选举为新的master。

ICMP测试,ping不通sw3的物理地址,ping通sw4的物理地址,ping通虚拟网关地址。

最后修改:2022 年 04 月 11 日
如果觉得我的文章对你有用,请随意赞赏