实训目的

· 掌握VRRP配置方法。

实训背景

VRRP(Virtual Router Redundancy Protocol,虚拟路由冗余协议)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议。配置VRRP的多备份组功能,增强出口网络稳健性,实现VRRP的负载均衡模式。

实训拓扑

实训所需设备:

环境:真机设备

设备: 4台PC,2台三层交换机,2台二层交换机

实训步骤

基本配置可参照书本

步骤1:配置交换机的VLAN、SVI地址、端口聚合

SW1:

Switch>en
Switch#conf t
Switch(config)#hostname SW1
SW1(config)#vlan 10
SW1(config-vlan)#vlan 20
SW1(config-vlan)#vlan 30
SW1(config-vlan)#vlan 40
SW1(config-vlan)#exit
SW1(config)#int vlan10
SW1(config-if)#ip address 192.168.10.1 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)#int vlan20
SW1(config-if)#ip address 192.168.20.1 255.255.255.0
SW1(config-if)#no shutdown
SW1(config)#int vlan30
SW1(config-if)#ip address 192.168.30.1 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)#int vlan40
SW1(config-if)#ip address 192.168.40.1 255.255.255.0
SW1(config-if)#no shutdown
SW1(config)#interface range e0/2-3
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config)#int range e0/0-1
SW1(config-if-range)#channel-group 1 mode active   //创建链路端口聚合,接口配置为LACP的active模式
SW1(config-if-range)#exit
SW1(config)#interface port-channel 1  //创建逻辑接口
SW1(config-if)#switchport trunk encapsulation dot1q   //封装802.1q
SW1(config-if)#switchport mode trunk  //设为trunk模式

SW2:

Switch>en
Switch#conf t
Switch(config)#hostname SW2
SW2(config)#vlan 10
SW2(config-vlan)#vlan 20
SW2(config-vlan)#vlan 30
SW2(config-vlan)#vlan 40
SW2(config-vlan)#exit
SW2(config)#int vlan10
SW2(config-if)#ip address 192.168.10.2 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#int vlan20
SW2(config-if)#ip address 192.168.20.2 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#int vlan30
SW2(config-if)#ip address 192.168.30.2 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#int vlan40
SW2(config-if)#ip address 192.168.40.2 255.255.255.0
SW2(config-if)#no shutdown
SW2(config)#interface range e0/2-3
SW2(config-if-range)#switchport trunk encapsulation dot1q
SW2(config-if-range)#switchport mode trunk
SW2(config)#int range e0/0-1
SW2(config-if-range)#channel-group 1 mode active   //创建链路端口聚合,接口配置为LACP的active模式
SW2(config-if-range)#exit
SW2(config)#interface port-channel 1  //创建逻辑接口
SW2(config-if)#switchport trunk encapsulation dot1q   SW2(config-if)#switchport mode trunk

SW3:

SW3(config)#vlan 10
SW3(config-vlan)#vlan 20
SW3(config-vlan)#exit
SW3(config)#interface e0/0
SW3(config-if)#switchport access vlan 10
SW3(config-if)#exit
SW3(config)#interface e0/1
SW3(config-if)#switchport access vlan 20
SW3(config)#interface range e0/2-3
SW3(config-if-range)#switchport trunk encapsulation dot1q
SW3(config-if-range)#switchport mode trunk

SW4:

SW4(config)#vlan 30
SW4(config-vlan)#vlan 40
SW4(config-vlan)#exit
SW4(config)#int e0/0
SW4(config-if)#switchport access vlan 30
SW4(config-if)#int e0/1
SW4(config-if)#switchport access vlan 40
SW4(config-if)#int range e0/2-3
SW4(config-if-range)#switchport trunk encapsulation dot1q
SW4(config-if-range)#switchport mode trunk
步骤2:配置SW1、SW2基于SVI多备份组的VRRP

SW1:

SW1(config)#interface vlan 10
SW1(config-if)#vrrp 10 priority 120  //站在SW1来说, 指定vlan10的流量经过虚拟路由网关192.168.10.254,划分 VRRP组10为优先级
SW1(config-if)#vrrp 10 ip 192.168.10.254
SW1(config-if)#vrrp 11 ip 192.168.10.253   //划分VRRP组11,默认优先级为100(优先级最高为255)
SW1(config-if)#int vlan20
SW1(config-if)#vrrp 20 ip 192.168.20.254
SW1(config-if)#vrrp 21 ip 192.168.20.253
SW1(config-if)#vrrp 21 priority 120  //划分VRRP组21为优先级
SW1(config)#int vlan30
SW1(config-if)#vrrp 30 ip 192.168.30.254
SW1(config-if)#vrrp 31 ip 192.168.30.253
SW1(config-if)#vrrp 30 priority 120  //划分VRRP组30为优先级
SW1(config-if)#int vlan40
SW1(config-if)#vrrp 40 ip 192.168.40.254
SW1(config-if)#vrrp 41 ip 192.168.40.253
SW1(config-if)#vrrp 41 priority 120  //划分VRRP组41为优先级

SW2:

SW2(config)#int vlan10
SW2(config-if)#vrrp 10 ip 192.168.10.254
SW2(config-if)#vrrp 11 ip 192.168.10.253
SW2(config-if)#vrrp 11 priority 120  //划分VRRP组11为优先级
SW2(config)#int vlan20
SW2(config-if)#vrrp 20 ip 192.168.20.254
SW2(config-if)#vrrp 21 ip 192.168.20.253
SW2(config-if)#vrrp 21 priority 120    //划分VRRP组21为优先级
SW2(config-if)#int vlan30
SW2(config-if)#vrrp 30 ip 192.168.30.254
SW2(config-if)#vrrp 31 ip 192.168.30.253
SW2(config-if)#vrrp 31 priority 120  //划分VRRP组31为优先级
SW2(config)#int vlan40
SW2(config-if)#vrrp 40 ip 192.168.40.254
SW2(config-if)#vrrp 41 ip 192.168.40.253
SW2(config-if)#vrrp 40 priority 120   //划分VRRP组40为优先级
步骤3:测试验证

SW1:

可以看出,SW1在 VRRP组10、20、30、41中的状态为主路由。

SW2:

可以看出,SW2在 VRRP组11、21、31、40中的状态为主路由。

最后修改:2022 年 04 月 11 日
如果觉得我的文章对你有用,请随意赞赏