实训目的

· 掌握BGP配置。

实训背景

BGP(Border Gateway Protocol,边界网关协议)是运行于TCP上的一种自治系统的路由协议。BGP是唯一一个用来处理因特网规模的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。BGP构建在EGP的经验之上。BGP系统的主要功能是和其他的BGP系统交换网络可达信息。网络可达信息包括列出的自治系统(AS)的信息。这些信息有效地构造了AS互联的拓朴图并由此清除了路由环路,同时在AS级别上可实施策略决策。

应用范围

BGP可用于电信、网通、移动、教育网之间互联。不同国家、不同运营商(Carrier) 之间也可用BGP互联。

实训拓扑

实验所需设备:

环境:Cisco Packet Tracer 8.0
设备:2台普通 PC,2台路由器

实训步骤

步骤1:基本配置。

R1:

Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#hostname R1
R1(config)#

R2:

Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#hostname R2
R2(config)#
步骤2:全网基本IP地址配置。
R1(config)#interface g0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface g0/1
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if1)#exit
R1(config)#
R2(config)#interface g0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#exit
R2(config)#interface g0/1
R2(config-if)#ip address 192.168.20.1 255.255.255.0
R2(config-if)#exit
R2(config)#
步骤3:配置BGP邻居。

注意:若BGP邻居的AS号与自己的AS号一致,建立的是IBGP邻居关系,若BGP邻居的AS号与自己的AS号不一致,建立的是BGP邻居关系。

R1(config)#router bgp 1
R1(config-router)#neighbor 192.168.1.2 remote-as 2
R1(config-router)#exit
R1#
R2(config)#router bgp 2
R2(config-router)#neighbor 192.168.1.1 remote-as 1
R2(config-router)#exit
R2#
步骤4:将路由告知BGP进程。

注意:network命令,在BGP里面是将哪些路由通告到BGP进程,并非对哪些接口启用BGP协议(与RIP和OSPF含义是不一样),network命令通告的路由,必须本地show ip route有这条路由,且掩码与mask参数的掩码一致,才能通告到BGP进程。

R1(config)#router bgp 1
R1(config-router)#network 192.168.10.0 mask 255.255.255.0
R1(config-router)#end
R1#
R2(config)#router bgp 2
R2(config-router)#network 192.168.20.0 mask 255.255.255.0
R2(config-router)#end
R2#m
步骤5:查看路由器之间是否建立BGP邻居关系,及邻居状态。若邻居关系可以正常建立,且状态为Established,则BGP运行正常。
R2#show ip bgp summary

步骤6:查看BGP邻居路由器的路由,若能学习到对方通告的路由,则BGP配置正确。
R2#show ip route

最后修改:2022 年 06 月 06 日
如果觉得我的文章对你有用,请随意赞赏