实训目的

·掌握MSTP 协议的工作原理。

·掌握MSTP 的网络环境部署

实训背景

某企业网络管理员认识到,传统的生成树协议(STP)是基于整个交换网络产 生一个树形拓扑结构,所有的 VLAN 都共享一个生成树,这种结构不能进行网络
流量的负载均衡,使得有些交换设备比较繁忙,而另一些交换设备又很空闲,为 了克服这个问题,他决定采用基于 VLAN 的多生成树协议 MSTP,现要在交换机上 做适当配置来完成这一任务。 网络采用 4 台交换机设备,PC1 和 PC3 在 Vlan 10 中,IP 地址分别为 172.16.1.10/24 和 172.16.1.30/24,PC2 在 Vlan 20 中,PC4 在
Vlan 40 中。

1、SW-C 作为 VLAN10 的根网桥,作为 VLAN20 和 VLAN40 的备份根网桥;

2、SW-D 作为 VLAN20 和 VLAN40 的根网桥,作为 VLAN10 的备份根网桥;

3、核心设备间互联链路加入聚合组,以提高可靠性;

4、实现网络冗余和可靠性的同时实现负载均衡(分担);

5、并通过相关命令验证试验结果。

实训拓扑

实验所需设备:

环境:EVE

设备: 4台PC,2台三层交换机,2 台二层交换机

实训步骤

步骤1:在二层接入交换机SW-A、SW-B、SW-C、SW-D上划分VLAN并配置trunk。

SW-A:

Ruijie>en
Ruijie#configure
Ruijie(config)#hostname SW-A
SW-A(config)#vlan 10
SW-A(config-vlan)#vlan 20
SW-A(config-vlan)#vlan 40
SW-A(config-vlan)#exit
SW-A(config)#interface e1/1
SW-A(config-if)#switchport access vlan 10
SW-A(config-if)#interface e1/2
SW-A(config-if)#switchport access vlan 20
SW-A(config-if)#exit
SW-A(config)#interface range e0/1-2
SW-A(config-if-range)#switchport trunk encapsulation dot1q
SW-A(config-if-range)#switchport mode trunk

SW-B:

Ruijie>en
Ruijie#configure
Ruijie(config)#hostname SW-B
SW-B(config)#vlan 10
SW-B(config-vlan)#vlan 20
SW-B(config-vlan)#vlan 40
SW-B(config-vlan)#exit
SW-B(config)#interface e1/1
SW-B(config-if)#switchport access vlan 10
SW-B(config-if)#interface e1/2
SW-B(config-if)#switchport access vlan 20
SW-B(config-if)#exit
SW-B(config)#interface range e0/1-2
SW-B(config-if-range)#switchport trunk encapsulation dot1q
SW-B(config-if-range)#switchport mode trunk

SW-C:

Ruijie>en
Ruijie#configure
Ruijie(config)#hostname SW-C
SW-C(config)#vlan 10
SW-C(config-vlan)#vlan 20
SW-C(config-vlan)#vlan 40
SW-C(config-vlan)#exit
SW-C(config)#interface range e0/0-2
SW-C(config-if-range)#switchport trunk encapsulation dot1q
SW-C(config-if-range)#switchport mode trunk

SW-D:

Ruijie>en
Ruijie#configure
Ruijie(config)#hostname SW-C
SW-C(config)#vlan 10
SW-C(config-vlan)#vlan 20
SW-C(config-vlan)#vlan 40
SW-C(config-vlan)#exit
SW-C(config)#interface range e0/0-2
SW-C(config-if-range)#switchport trunk
encapsulation dot1q
SW-C(config-if-range)#switchport mode trunk

步骤2:在二层交换机SW-A、SW-B上配置MTSP

SW-A(config)# spanning-tree mode mst   //配置生成树模为MSTP
SW-A(config)#spanning-tree mst configuration  //进入MSTP配置模式SW-A(configmst)#instance 1 vlan 1,10      //配置实例1并关联vlan1、vln10
SW-A(config-mst)#instance 2 vlan 20,40 //配置实例1并关联vlan20、vln40
SW-A(config-mst)#name region1  //配置域名为region1
SW-A(config-mst)#revision 1   //配置修订号
SW-A(config-mst)#exit
SW-B(config)# spanning-tree mode mst   //配置生成树模为MSTP
SW-B(config)#spanning-tree mst configuration  //进入MSTP配置模式SW-B(config-mst)#instance 1 vlan 1,10
SW-B(config-mst)#instance 2 vlan 20,40
SW-B(config-mst)#name region1
SW-B(config-mst)#revision 1
SW-B(config-mst)#exit

步骤3:在三层汇聚交换机SW-C、SW-D上配置MSTP

SW-C(config)# spanning-tree mode mst   //配置生成树模为MSTP
SW-C(config)# spanning-tree mst 1 priority 4096   //实例1的优先级为4096,为实例1的根
SW-C(config)#spanning-tree mst configuration  //进入MSTP配置模式SW-C(config-mst)#instance 1 vlan 1,10
SW-C(config-mst)#instance 2 vlan 20,40
SW-C(config-mst)#name region1
SW-C(config-mst)#revision 1
SW-C(config-mst)#exit
SW-D(config)# spanning-tree mode mst   //配置生成树模为MSTP
SW-D(config)# spanning-tree mst 2 priority 4096   //实例2的优先级为4096,为实例2的根
SW-D(config)#spanning-tree mst configuration  //进入MSTP配置模式SW-D(configmst)#instance 1 vlan 1,10
SW-D(config-mst)#instance 2 vlan 20,40
SW-D(config-mst)#name region1
SW-D(config-mst)#revision 1
SW-D(config-mst)#exit

步骤4:测试验证

查看SW-A、SW-B的MSTP配置

查看SW-C、SW-D的MSTP配置

最后修改:2022 年 04 月 11 日
如果觉得我的文章对你有用,请随意赞赏