实训目的

· 了解动态路由协议。

· 了解OSPF的基本原理。

· 掌握OSPF的配置方法。

实训背景

动态路由协议

根据是否在一个自治域(Autonomous System,AS)内部使用,动态路由协议分为 IGP (Interior Gateway Protocol,内部网关协议)和 EGP (Exterior Gateway Protocol, 外部网关协议)。这里的自治域指一个具有统一管理机构、统一路由策略的网络。内部网关协议常用的有RIP、OSPF,外部网关协议常用的是BGP,主要用于多个自治域之间的路由选择。

OSPF路由协议

OSPF(Open Shortest Path First, 开放式最短路径优先)协议是一个内部网关协议(Interior Gateway Protocol,IGP),用于在单一自治系统(Autonomous System,AS)内决策路由。

链路状态

链路状态通告(Link-State Advertisement, LSA)就是OSPF接口上的描述信息,例如接口上的IP地址,子网掩码,网络类型,Cost值等等,OSPF路由器之间交换的并不是路由表,而是链路状态(LSA),OSPF通过获得网络中所有的链路状态信息,从而计算出到达每个目标精确的网络路径。OSPF路由器会将自己所有的链路状态毫不保留地全部发给邻居,邻居将收到的链路状态全部放入链路状态数据库(Link-State Database),邻居再发给自己的所有邻居,并且在传递过程中,绝对不会有任何更改。通过这样的过程,最终网络中所有的OSPF路由器都拥有网络中所有的链路状态,并且所有路由器的链路状态应该能描绘出相同的网络拓朴。

实训拓扑

实验所需设备:

环境:Cisco Packet Tracer 8.0
设备: 2台PC,2台2811路由器

实训步骤

步骤1:基本配置

配置网关

R1:

Router>enable 
Router#configure t
Router(config)#hostname R1
R1(config)#interface f0/1
R1(config-if)#ip add 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface f0/0
R1(config-if)#no shutdown 
R1(config-if)#ip add 192.168.1.1 255.255.255.0

R2:

Router>enable 
Router#configure t
Router(config)#interface f0/0
Router(config-if)#no shutdown 
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config)#interface f0/1
Router(config-if)#no shutdown 
Router(config-if)#ip address 192.168.3.1 255.255.255.0

配置OSPF动态路由,实现全网互通。

R1:

R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 1
R1(config-router)#network 192.168.2.0 0.0.0.255 area 1

R2:

Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.255 area 1
Router(config-router)#network 192.168.3.0 0.0.0.255 area 1
步骤2:测试验证,使用show ip route命令查看路由条目,可以看到有一条为O的路由条目。
R1#show ip route

步骤3:测试PC1与PC2的连通性。

最后修改:2022 年 05 月 22 日
如果觉得我的文章对你有用,请随意赞赏